Ошибка при попытке использовать соединение mysql на Apache Tomcat Cloud Server (спящий режим)

У меня ошибка при попытке запустить мое веб-приложение на веб-сервере facilcloud (jelastic), мой проект работает с mysql hibernate, mongodb, java 1.6, spring mvc, bootstrap, maven и другими инструментами.

Проблема у меня возникает, когда я запускаю приложение, уже развернутое на сервере в облаке. Из индекса я пытаюсь создать пользователя приложения, и оно застревает, потому что в журнале apache tomcat есть ошибка со следующим сообщением, к которому я обращался, относится к версии jdk, но я попытался создать сервер с той же версией jdk и измените версию jdk моего проекта через eclipse, и эта ошибка продолжается, спасибо за сотрудничество.

Я прилагаю образы конфигурации моей локальной среды с версиями jdk, которые я использую для компиляции, и версией jdk самого проекта.

ИНФОРМАЦИЯ: org.springframework.beans.factory.support.DefaultListableBeanFactory - Предварительные экземпляры синглетонов в org.springframework.beans.factory.support.DefaultListableBeanFactory@527a9c0ff: определение бобов internalConfigurationAnnotationProcessor, org.springframework.context.annotation.internalAutowiredAnnotationProcessor, org.springframework.context.annotation.internalRequiredAnnotationProcessor, org.springframework.context.annotation.internalCommonAnnotationProcessor, mongoConfig, org.springframework.context.annotation.ConfigurationClassPostProcessor $ ImportAwareBeanPostProcessor # 0, mongoDbFactory, mongoTemplate]; тест корневой иерархии фабрики--testt--1234567378--drizzleweb@icloud.com--2002-03-19--1234567890--0 Ошибка первоначального создания SessionFactory.java.lang.UnsupportedClassVersionError: org / hibernate / cfg / Configuration: Неподдерживаемая версия major.minor 52.0 (невозможно загрузить класс org.hibernate.cfg.Configuration)


Конфигурация приложения в локальной среде разработки:

Configuración de la applicación en el ambiente local de desarrollo

Версия JDK, с которой он компилируется и выполняется локально, в дополнение к версии локального веб-сервера:

Versión de JDK con el que se compila y ejecuta localmente, además de la versión del Servidor Web Local

0
задан 14.03.2017, 22:59
0 ответов

В соответствии с документацией:

Thrown when the Виртуальный Java Machine attempts to read в class file and определи that the major and minor версию numbers in the file пашите not supported.

На испанском языке:

Она брошена, когда JVM пробует читать файл .class и определи, что самая меньшая и большая версия в файле не вынесены.

Initial SessionFactory creation failed.java.lang.UnsupportedClassVersionError:
org/hibernate/cfg/Configuration : Unsupported major.minor version 52.0 (unable 
to load class org.hibernate.cfg.Configuration)

Говори об ошибке в версии 52.0(java 8), что как wikipedia:

  1. Java Я ЗНАЮ 9 = 53
  2. Java Я ЗНАЮ 8 = 52
  3. Java Я ЗНАЮ 7 = 51
  4. Java Я ЗНАЮ 6.0 = 50
  5. Java Я ЗНАЮ 5.0 = 49
  6. JDK 1.4 = 48
  7. JDK 1.3 = 47
  8. JDK 1.2 = 46
  9. JDK 1.1 = 45

Это означает, что в Jelastic/Facilcloud он использует java 1.8 и согласно Вашим изображениям, локальная конфигурация - java 1.6

Убедитесь имения согласных версий, ésto был бы должен решать этот ошибку.

0
ответ дан 03.12.2019, 17:54