У меня есть ошибка с книжным магазином составьте 'com.android.support:design:25.0.1'

В момент включения libería:

compile 'com.android.support:design:25.0.1'

в моем app/build.gradle он бросает в меня ошибку:

this support library should not использовал в different версию (25) than the compilesdkversion (24)

Кто-то знает почему?

0
задан 22.01.2017, 13:20
0 ответов

Чтобы мочь использовать версию 25 из книжных магазинов опоры Google, у тебя должна быть версия SDK 25 и иметь конфигурировавший следующее.

android {
    compileSdkVersion 25
    buildToolsVersion "25.0.1"
    ...
    defaultConfig {
        ...
        targetSdkVersion 25

y después todas las dependencias de la librerías de soporte a 25

dependencies {
    compile 'com.android.support:appcompat-v7:25.1.0'
    compile 'com.android.support:design:25.1.0'
    compile 'com.android.support:cardview-v7:25.1.0'
    ...

Он может просить у тебя, что нужно устанавливать SDK 25, выходит, где он показывает себе ошибки.

1
ответ дан 03.12.2019, 17:35
  • 1
    пойдите спасибо, я понял верно и я я функционирую очень хорошо, только сомнение, которое у меня остается, - что в классах, что у меня есть в ней первый линия, где он признает себя package, в моем случае эта линия package com.example.jorge.chatapp;... он выходит у меня подчеркнутым в красном, я могу создавать apk без ошибок, но меня продолжают вытекать подчеркнутым в красном как будто это была ошибка и переместив курсор говорят мне это сообщение: the sdk platform-tools версия (24.0.4) is too old to check apis compiled with api 25; please update... просто я не замечаю его? или я должен менять какую-то versió n больше? –  22.01.2017, 13:23
  • 2
    Сейчас я делаю доказательства, вижу, что buildToolsVersion они существуют versió n 25, перешли 25.0.0 выйдет ошибка и устанавливать пакет –  22.01.2017, 15:05

Теги

Похожие вопросы