Почему, когда я верю в проект, он не приходит с 'implementation 'com.android.support:appcompat-v7:28.0.0'?

Я увидел остальных руководителей, которые, когда я буду верить в проект, им создается эта линия кода:

implementation 'com.android.support:appcompat-v7:28.0.0'
0
задан 28.12.2019, 05:56
1 ответ

Это происходит, которым IDE он обновлен в androidx, а именно, SDK compilaciГіn он приходит конфигурировавший по умолчанию для Android 9.0. Линия, о которой ты упоминаешь, состоит та librerГ - в опоры в том, что он использовал AndroidStudio для compilaciГіn в versiГіn android 8.0 (Я проветриваю). Тогда:

Эта линия:

implementation 'com.android.support:appcompat-v7:28.0.0'

Изменил в эту

implementation 'androidx.appcompat:appcompat:1.1.0'

Поэтому каждый раз, когда ты веришь в новый проект, того же самого будет создан конфигурировавший для android 9.0 automГЎticamente.

Для больше informaciГіn относительно этого, acГЎ у тебя есть documentaciГіn относительно темы. Привет и желанный в stackoverflow.

0
ответ дан 29.12.2019, 09:10
  • 1
    И если я хочу использовать опору с CardView, как я помещаю осуществление. – Joffre Andres Veloz 28.12.2019, 04:12
  • 2
    Здесь ты можешь находить mapeos, как они изменились с предыдущего устройства compilació n, в настоящего. Allí эта cardView. – David Villegas 28.12.2019, 04:18
  • 3
    Я прошу у тебя, что он большое спасибо не знал эту информацию. И ты знаешь как retoceder в ' Устройство compilació n anterior' – Joffre Andres Veloz 28.12.2019, 04:28