Мигрируя старый проект в недавнюю версию Андроид Студио 3.4.2

друзья я считаю проект 2016 года созданным в android studio, и я это хочу мигрировать для новой версии android studio v3.4.2, что является той, которую я использую, это проект, если ты хочешь проверить: Я проектирую

я старался делать это, чтобы заставлять это прокручивать изображение в окне в API 27, но меня производит эта ошибка:

ERROR: Failed to resolve: com.android.support:appcompat-v7:23.1.1
Add Google Maven repository and sync project
Show in Project Structure dialog
Affected Modules: app


ERROR: Failed to resolve: com.android.support:support-v4:23.0.0
Add Google Maven repository and sync project
Show in Project Structure dialog
Affected Modules: app

и это build gradle

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "23.0.2"

    defaultConfig {
        applicationId "com.epam.merl1n.info.privateblog.merl1nvision"
        minSdkVersion 19
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
        debug {
            debuggable true
        }
    }

    compileOptions {
        sourceCompatibility JavaVersion.VERSION_1_7
        targetCompatibility JavaVersion.VERSION_1_7
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile "com.android.support:support-v4:23.0.0"
    compile "com.android.support:gridlayout-v7:23.0.0"
    compile "com.android.support:cardview-v7:23.0.0"
    compile 'com.android.support:appcompat-v7:23.1.1'
}

как я могу делать, чтобы этого мигрировать???

0
задан 10.11.2019, 12:47
1 ответ

Ты должен издавать build.gradle и должен считать что-то этим:

allprojects {
        repositories {
            jcenter()
            google()
        }
    }

ты Должен издавать того, который находится в каталоге raГ-z проекта. AquГ - ты можешь находить mГЎs informaciГіn.

0
ответ дан 01.12.2019, 12:09
  • 1
    друг, который ты имеешь в виду, это старалось делать вчера, когда añ adi google () я бросаю ошибку, которая не знала эту функцию – Gerson Arias Cardenas 11.11.2019, 00:59
  • 2
    Если это не функционирует, из-за которого ты не создаешь новый проект, и despué s только ты копируешь có я говорю шрифт, что está в папке src. – FrEqDe 11.11.2019, 01:24
  • 3
    FrEqDe проверил и в каталоге проекта он не эта папка....., если ты можешь, проверяет здесь эту и проект, что я работаю 4shared.com/rar/uMWIbl8Tiq/Merl1nVision.html – Gerson Arias Cardenas 11.11.2019, 01:36
  • 4
    FrEqDe применился которое я recomendastes и я функционирую..... sync составил без проблем, сейчас, когда я пошел производить apk в Хенерате Сигнед Build / APK, я произвожусь ошибка. – Gerson Arias Cardenas 11.11.2019, 04:27
  • 5
    Ты должен определять, что ты получил ошибку, это важно. – Jorgesys♦ 11.11.2019, 17:00

Теги

Похожие вопросы