Обновлять Java 1.5 в 1.8 в Приложении

Я рассказываю вам, у меня есть приложение, что находится в Java 1.5, приказали перемещать нас в Java 1.8, но не переделывая ее, просто изменяя файлы конфигурации для того, чтобы был приготовлен в java 1.8.

Хорошо, я читал и почти во всех сайтах он помещал обновления pom для того, чтобы, вместо которого версия java была 5, было 8. проблемы, дело в том, что в этом приложении в частности нет pom.xml, так как он не в spring.

Приложение прямо сейчас desplega в jboss и идее состоит в том, чтобы с java 8 развернулся в tomcat...

Чтобы давать больше информации, также он используется ivy.xml.

Но прямо сейчас я не вижу очень хорошо, что файлы были бы должны покрывать, чтобы обновлять версию.

Ты мог бы давать мне немного света на этой теме?

Большое спасибо!

0
задан 07.11.2019, 17:12
1 ответ

Если estГЎs используя Затмение, bastarГ - чтобы с менять Прохектс Фасетс.

В project explorer , сделай click право на:

Проектировал-> Properties-> Прохект Фасетс.

TambiГ©n ты это можешь делать asГ -

Ctrl + 3. Пишет Прохект Фасетс

Una vez внутри, ищет Java, и меняет versiГіn 1.5 в 1.8.

Кликни в Apply and Close. , и повторно составлять проект:

Project-> Clean

TambiГ©n ты можешь менять ее configuraciГіn в:

Project-> Properties-> Java Compiler

Desde aquГ - выбирать ее versiГіn Java.

Надеялся, что он служит тебе помощью.

-1
ответ дан 01.12.2019, 12:27
  • 1
    Но это не está не меняя никакого файла конфигурации, нет? а именно, я понимаю, чем в проекте habrá файлы configuració n, где ты сказал ему, что его java 1.5, и делая это этой формой, не изменяется ничто. – Javier 07.11.2019, 17:16
  • 2
    В затмении, configuració n проекта он находится внутри папки .settings, в файле org.eclipse.jdt.core.prefs. Ahí он, где он меняется, когда ты касаешься facets. – Francisco Javier Cuena Serrano 07.11.2019, 17:26
  • 3
    Я представляю, что ты preguntará s, ¿ Có mo узнай среду ejecució n (JRE), который должен относиться к aplicació n как Java 8? Потому что, составив проект с JDK 8, у твоих вытекающих .class есть признак, major, который он показывает qué versió n JDK он это составил. Поэтому, JRE не нуждается в файле configuració n, чтобы знать versió n Java твоего aplicació n. – Francisco Javier Cuena Serrano 07.11.2019, 17:36

Теги

Похожие вопросы