Ошибка с com.android.support:appcompat-v7:19.1.0 API 19

Друзья я работаю в app geolocalizacion, для android v 4.4 и там я использую appcompat-v7, но меня производит ошибка благодаря тому, что он не хорошо конфигурировался, уже я сделал изменения, но он не следует мне, тогда я обращаюсь к Вам для того, чтобы они помогли мне пожалуйста, здесь код: apply plugin: 'com.android.application'

android {
    compileSdkVersion 19
    buildToolsVersion "23.0.3"

    defaultConfig {
        applicationId "com.academiaandroid.datosgps"
        minSdkVersion 15
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.13-rc-1'
    compile 'com.android.support:appcompat-v7:19.1.0'
}

и это произведенная ошибка:

ERROR: Failed to resolve: com.android.support:appcompat-v7:19.1.0
Affected Modules: app
0
задан 02.11.2019, 05:13
1 ответ

ты определяешь в твоем проекте одном compileSdkVersion 19 и targetSdkVersion 23, эти версии устаревшие , даже использование compile устаревшее, должно быть использованным:

implementation 'com.android.support:appcompat-v7:19.1.0'

в самом деле ты нуждаешься в том, чтобы обновить в versiГіn 26 как mГ-nimo, так как это показано Google:

introducir la descripción de la imagen aquí

Обновляет Андроид Студио и определяет как mГ-nimo:

compileSdkVersion 26 и targetSdkVersion 26

0
ответ дан 01.12.2019, 13:04
  • 1
    но если они не дают ему больше опоры версиям как 4.4.2 (API 19), из-за которых android Studio позволил мне загружать счастье API, это было средой прошлой недели..... я не понимаю –  Gerson Arias Cardenas 05.11.2019, 13:55

Теги

Похожие вопросы