Fill down до определенного ранга

Я пробую облегчать себе работу и мне хотелось бы знать, как писать в макросе, что я тащил формулу до динамического ранга, который я определил ранее.

Макрос - следующий: MACRO

Динамический ранг называется datos3.

0
задан 21.10.2019, 00:37
1 ответ

Прямо сейчас я не могу видеть изображения, но комментирую тебе. Чтобы тащить формулу с линии в частности до конца ранга ты можешь делать это. Давайте предполагать, что ты хочешь тащить твою формулу с линии 2 колонны H до конца этой колонны:

Application.screenupdating = false

Dim sht as worksheet
Dim uf as long
Set sht = thisworkbook.Sheets("MiHoja")
uf = sht.Cells(Rows.Count, 1).End(xlUp).Row 'Ultima fila con datos. 

With sht.range("H2:H" & uf)

    .formulalocal = "=SUMA(E2+I2)" 'Con esto arrastras la fórmula desde la fila 2
    .formulalocal = .value        'Con esto conviertes la formula en un valor para evitar que se muestre la formula.

End With

Application.screenupdating = True

типов Привета.

0
ответ дан 24.10.2019, 23:38