Как присвоить номер тексту в Excel?

Я занимался расследованием, и я нигде не нашел, или, может быть, я не полностью понял это в таблице Excel, мы поместили форму с ответами, и у каждого ответа есть значение для добавления, например

creo que si = 2
creo que no = 3
no = 4

Есть ли способ, чтобы вместо того, чтобы делать это вручную, изменяя значения, а затем добавляя их, Excel идентифицирует меня в тексте и может присвоить это значение ему и произвести автоматическое изменение? Я пытался создавать макросы и использовать VBA, но мои знания не так широки, как данные, есть 27 вопросов, и я имел в виду какой-то макрос, который бы идентифицировал меня для каждого ответа и назначил значение, а затем добавил его, все в форме строк

0
задан 03.12.2019, 19:47
1 ответ

Ты можешь aГ±adir колонна с условным, это что-то обременительное чтения, но функционирует

=SI(B2="creo que si";2;SI(B2="creo que no";3;SI(B2="no";4;0)))

DГіnde B2 - та posiciГіn текста.

, Если ты имеешь Excel по отношению к

=IF(B2="creo que si";2;IF(B2="creo que no";3;IF(B2="no";4;0)))
на английском serГ -
0
ответ дан 03.12.2019, 21:42
  • 1
    если я нашел этот пример, но проблема состоит, в том, что, как это формуляр, у не всех колонн B2 есть ответ, я верю в то, что, если, все различные, не, если я объясняюсь – ruben antonio placencia rivera 03.12.2019, 19:44
  • 2
    или жди, и я прочитал добро, извинение, ты прав, но другая информация, которая переместила помещать меня, он состоял в том, что это 27 вопросов, солитер в разуме и не, если могут, какой-то макрос, который идентифицировался бы это и после это складывал – ruben antonio placencia rivera 03.12.2019, 19:45