Проблемы с JavaFX в NetBeans

Я использую NetBeans, и я начинаю работу в JavaFX , но когда я пытаюсь создать проект «Приложение FX» , я получаю следующую ошибку:

Не удалось автоматически настроить платформу JavaFX. Перейдите в диспетчер платформ, создайте нестандартную платформу Java SE, затем перейдите на вкладку JavaFX, включите JavaFX и введите пути к действующим JavaFX SDK и JavaFX Runtime. Примечание. JavaFX SDK можно загрузить с веб-сайта JavaFX.

Это то, что я установил до сих пор:

  • NetBeans 11
  • JDK 12

Я понял, что функции, необходимые для использование JavaFX уже включено в JDK 12, или я все еще что-то упускаю? Могли ли версии, которые я установил, быть проблемой?

Доброе утро, и большое спасибо за то, что вы уделили мне время для ответа.

1
задан 14.06.2019, 18:12
1 ответ

DespuГ©s ее versiГіn JDK 8, JDK (что это сейчас OpenJDK ) не приносит опора для JavaFx , но если возможно создавать приложения JavaFx добавляя SDK OpenJFX это загружая с Ваш Веб . Инструкции немного длинные, aquГ - есть хорошая одна explicaciГіn в видео .

-1
ответ дан 02.12.2019, 00:47