Проблема с bluetooth в slackware 14.2 current

После kernel обновил раньше в версию 4.4.6, как GUI bluetooth, так и какие-то другие вещи (например. соединять устройство из-за bluetooth) они не функционируют.

Вещи, которые я протестировал, были следующими:

  • переоборудовать package bluetooth (blueman) без успеха
  • также desinstalarlo и вновь устанавливать это
  • возобновлять услугу

Будучи пользователем он дает мне:

Starting Bluetooth services: 

 bluetoothd hciconfig sdptool hciattach D-Bus setup failed: Connection ":1.58" is not allowed to own the service "org.bluez" due to security policies in the configuration file
rfcomm

И будучи root он это инициализирует хорошо без ошибки или с sudo также он это инициализирует хорошо.

dmesg | grep -i blue
[ 6.623881] Bluetooth: Core ver 2.21
[ 6.623897] Bluetooth: HCI device and connection manager initialized
[ 6.623901] Bluetooth: HCI socket layer initialized
[ 6.623903] Bluetooth: L2CAP socket layer initialized
[ 6.623908] Bluetooth: SCO socket layer initialized
[ 15.270804] Bluetooth: BNEP (Ethernet Emulation) ver 1.3
[ 15.270808] Bluetooth: BNEP filters: protocol multicast
[ 15.270812] Bluetooth: BNEP socket layer initialized

hcitool dev
Devices:
hci0 4C:EB:42:7F:C1:6D


rfkill list bluetooth
1: hci0: Bluetooth
Soft blocked: no
Hard blocked: no

уже я не знаю, что пытаться, раньше оно функционировало гениально, но сейчас не, и у меня нет намерения делать downgrade!

12
задан 30.03.2016, 07:53
1 ответ

Я думаю, что ты сами инициализировал трэд здесь, где они объясняют решение (и я выставляю ее для будущих ссылок), которое приближается многий к тому, что уже ты комментировал в твоем вопросе, но с конкретным порядком, что очень важно поддерживать:

  1. Для процесса bluetoothf с:

/etc/rc.d/rc.bluetooth stop

  1. Удали пакет bluez

removepkg bluez

  1. Переоборудуй пакет bluez:

slackpkg update

slackpkg install bluez

/etc/rc.d/rc.bluetooth start

И решенный.

Кроме того, когда ты делаешь шагом 2 удаления bluez у тебя появятся много сообщений (не беспокойся поэтому), которые могут быть информационными, если есть какая-то ошибка, но хотя это будет так, mientres desinstale, не важно.

2
ответ дан 24.11.2019, 14:41