ошибка, установив dingo/api

я стараюсь устанавливать dingo/api для api rest в laravel 5.1, но когда я выполняю composer require dingo/api:1.0.x@dev он бросает в меня эту ошибку:

Your requirements could not be решите to an installable set of packages.

Problem 1

  • dingo/api 1.0.x-dev requires dingo/blueprint 0.2.*-> satisfiable by dingo/blueprint [0.2.x-dev] but these conflict with your requirements or minimum-stability.
    • Заключение: don't install dingo/api v1.0.0-beta3
    • Заключение: don't install dingo/api v1.0.0-beta2
    • Заключение: remove phpdocumentor/reflection-docblock 3.1.0
    • Installation request for dingo/api 1.0.x@dev-> satisfiable by dingo/api [1.0.x-dev, v1.0.0-beta1, v1.0.0-beta2, v1.0.0-beta3].
    • Заключение: don't install phpdocumentor/reflection-docblock 3.1.0
    • dingo/api v1.0.0-beta1 requires phpdocumentor/reflection-docblock 2.0.*-> satisfiable by phpdocumentor/reflection-docblock [2.0.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4].
    • Хан only install one of: phpdocumentor/reflection-docblock [2.0.0, 3.1.0].
    • Хан only install one of: phpdocumentor/reflection-docblock [2.0.1, 3.1.0].
    • Хан only install one of: phpdocumentor/reflection-docblock [2.0.2, 3.1.0].
    • Хан only install one of: phpdocumentor/reflection-docblock [2.0.3, 3.1.0].
    • Хан only install one of: phpdocumentor/reflection-docblock [2.0.4, 3.1.0].
    • Installation request for phpdocumentor/reflection-docblock (locked at 3.1.0)-> satisfiable by phpdocumentor/reflection-docblock [3.1.0].
Installation failed, reverting ./composer.json to its original content.

не, из чего проистекло это, спасибо заранее...

здесь контент моего composer.json:

{
"name": "laravel/laravel",
"description": "The Laravel Framework.",
"keywords": ["framework", "laravel"],
"license": "MIT",
"type": "project",
"require": {
    "php": ">=5.5.9",
    "laravel/framework": "5.1.*",
    "dingo/api": "1.0.x@dev"
},
"require-dev": {
    "fzaninotto/faker": "~1.4",
    "mockery/mockery": "0.9.*",
    "phpunit/phpunit": "~4.0",
    "phpspec/phpspec": "~2.1"
},
"autoload": {
    "classmap": [
        "database"
    ],
    "psr-4": {
        "App\\": "app/"
    }
},
"autoload-dev": {
    "classmap": [
        "tests/TestCase.php"
    ]
},
"scripts": {
    "post-root-package-install": [
        "php -r \"copy('.env.example', '.env');\""
    ],
    "post-create-project-cmd": [
        "php artisan key:generate"
    ],
    "post-install-cmd": [
        "Illuminate\\Foundation\\ComposerScripts::postInstall",
        "php artisan optimize"
    ],
    "post-update-cmd": [
        "Illuminate\\Foundation\\ComposerScripts::postUpdate",
        "php artisan optimize"
    ]
},
"config": {
    "preferred-install": "dist"
}
}
1
задан 28.06.2016, 20:36
2 ответа

ok conseguГ - ответ только debГ, - чтобы добавлять require composer.json phpdocumentor/reflection: 3.x@dev и потом dingo/api:1.0.x@dev и выполнять composer update и я заношу в список все funcionГі хорошо, asГ - quedГі composer.json:

{
"name": "laravel/laravel",
"description": "The Laravel Framework.",
"keywords": ["framework", "laravel"],
"license": "MIT",
"type": "project",
"require": {
    "php": ">=5.5.9",
    "laravel/framework": "5.1.*",
    "phpdocumentor/reflection": "3.x@dev",
    "dingo/api": "1.0.x@dev"
},
"require-dev": {
    "fzaninotto/faker": "~1.4",
    "mockery/mockery": "0.9.*",
    "phpunit/phpunit": "~4.0",
    "phpspec/phpspec": "~2.1"
},
"autoload": {
    "classmap": [
        "database"
    ],
    "psr-4": {
        "App\\": "app/"
    }
},
"autoload-dev": {
    "classmap": [
        "tests/TestCase.php"
    ]
},
"scripts": {
    "post-root-package-install": [
        "php -r \"copy('.env.example', '.env');\""
    ],
    "post-create-project-cmd": [
        "php artisan key:generate"
    ],
    "post-install-cmd": [
        "Illuminate\\Foundation\\ComposerScripts::postInstall",
        "php artisan optimize"
    ],
    "post-update-cmd": [
        "Illuminate\\Foundation\\ComposerScripts::postUpdate",
        "php artisan optimize"
    ]
},
"config": {
    "preferred-install": "dist"
}
}
0
ответ дан 24.11.2019, 13:58

Add "phpdocumentor/reflection": "3.x@dev" under "require": { } in composer.json and run в composer update

"require": {{113]

    "php": ">=5.5.9",
    "laravel/framework": "5.2.*",
    "phpdocumentor/reflection": "3.x@dev"

},

$ composer update $ composer require dingo/api:1.0.x@dev

after successful command this will add "dingo/api": "1.0.x@dev" under require.

"require": {{117]

    "php": ">=5.5.9",
    "laravel/framework": "5.2.*",
    "phpdocumentor/reflection": "3.x@dev",
    "dingo/api": "1.0.x@dev"

}

0
ответ дан 24.11.2019, 13:58
  • 1
    Hi Мохаммад. This сайт is for Spanish communication in all content: questions, answers, comments, и т.д. Please edit your answers and использовал Spanish, otherwise the post will be переместите. –   27.07.2016, 17:58