Error tras actualizar a cordova 6.4.0 en un proyecto con Meteor

Tengo un proyecto que estaba corriendo con cordova 6.3.1 y andaba todo ok. Despues de agregar phonegap-plugin-push empecé a tener problemas

%% Plugin doesn't support this project's cordova version. cordova: 6.3.1, failed version requirement: >=6.4.0
%% Skipping 'phonegap-plugin-push' for android                                  
%% Plugin doesn't support this project's cordova version. cordova: 6.3.1, failed version requirement: >=6.4.0
%% Skipping 'phonegap-plugin-push' for ios   

Asi que actualice cordova a 6.4.0 (meteor add cordova:cordova@6.4.0) y ahora estoy teniendo otros problemas.

=> Errors executing Cordova commands:                                           

   While adding plugin cordova@6.4.0 to Cordova project:                        
   Cordova error: Cannot find plugin.xml for plugin "package". Please try       
   adding it again.
   (If the error message contains suggestions for a fix, note that this may not 
   apply to the Meteor integration. You can try running again with the
   --verbose option to help diagnose the issue.)

/Users/diegodedieu/.meteor/packages/meteor-tool/.1.4.2.tjodye++os.osx.x86_64+web.browser+web.cordova/mt-os.osx.x86_64/isopackets/runtime/npm/node_modules/meteor/promise/node_modules/meteor-promise/promise_server.js:190
  throw error;
  ^
  ExitWithCode:1

Como puedo solucionar estos problemas?

2
задан 07.11.2016, 19:38
2 ответа

Meteor приносит версию интегрированного Cordova (https://github.com/meteor/meteor/blob/master/scripts/dev-bundle-tool-package.js#L57), ты не можешь обновлять ее.

Когда ты делаешь meteor add cordova:cordova@6.4.0 ты сводишь его с ума, потому что думается, что ты добавляешь plugin, и поэтому говорит тебе, что нет plugin.xml, потому что Cordova не plugin и у него нет одного plugin.xml

Пока ты будешь должен использовать предыдущую версию plugin (1.8.4) до тех пор, пока meteor он не обновит cordova-lib в 6.4.0

1
ответ дан 24.11.2019, 12:42
  • 1
    Спасибо, в конце концов я смог вновь заставлять проходить это, но с версией 6.3.1. –  Diego De Dieu 14.11.2016, 14:54

То же сообщение показывает тебе проблему,

%% Plugin doesn't support this project's cordova версия. cordova: 6.3.1, failed версия requirement:> =6.4.0 %% Skipping 'phonegap-plugin-push' for android

plugin versiГіn 1.9.0, требует как mГ-nimo версия 6.4.0.

https://github.com/phonegap/phonegap-plugin-push/blob/master/docs/INSTALLATION.md

0
ответ дан 24.11.2019, 12:42
  • 1
    Если, он поэтому состоит в том, чтобы он обновил 6.4.0, и там, где я trancado сейчас, в другой ошибке –  Diego De Dieu 07.11.2016, 21:09