Forbidden, ошибка 403 с Apache/2.4.6

Я конфигурирую Apache/2.4.6 на сервере Centos 7. Я создал виртуальный host следующего способа:

<VirtualHost {IP}:80->
    ServerAdmin admin@localhost
    DocumentRoot /home/monkey/site/public
    ServerName www.monkey.net:80
    ServerAlias monkey.net
    ErrorLog /home/monkey/error.log
    CustomLog /home/monkey/requests.log combined
</VirtualHost>

Кроме того, (как я) установил директивный орган для permiter в индейца-апачиа доступ к вышеупомянутой папке:

<Directory "/home/monkey/site/public">
    Allow from all
</Directory>

Однако, во время ввождения информацию в компьютер в monkey.net он дает мне следующую ошибку в браузере:

Forbidden

You don't have permission to access / on this server.

Я перешел, чтобы делать какие-то изменения посмотрим он давал ему решение, но ошибка еще остается там:

  1. Давать разрешения написания и чтения в /home/monkey/site/ в /home/monkey/site/public с одним chmod 755/777.
  2. Устанавливать тип каталога site/ с командой:

    chcon -h system_u:object_r:httpd_sys_content_t /home/monkey/site/public 
    

Наблюдая logs я вижу, что ошибка подробно описывается следующего способа:

[core:error] [pid 7925] (13) Permission denied: [client 186.15.110.196:56917] AH00035: access to / denied (filesystem path '/home/monkey/site') because search permissions пашите missing on в component of the path

Googleando, главным образом то, что они рекомендуют, состоит в том, чтобы делать то, что уже я сделал, но без положительных результатов. Я не знаю, буду перемещать ли я что-то из-за высокого. Привет

Редактирование 29.01.2016: SELinux, кажется, не является барьером, так как /var/log/audit/audit.log он не показывает сообщения "access denied". Я могу покупать это делая:

# ausearch -m AVC --start today -i

Относительно разрешения каталогов, я применил 644 ко всем каталогам до root:

// 755 /home/monkey/site/public/index.php
4 -rwxr-xr-x  index.php

// 644 /home/monkey/site/public/
0 drw-r--r-- 4  public

// 644 /home/monkey/site/
0 drw-r--r-- 4  site

...
5
задан 29.01.2016, 20:11
4 ответа

Дополняя тему репутации после того, как, в общем, будучи внутри home, необходимо применять разрешения выполнения к другим пользователям машины. Разы, что у меня была эта проблема, я это решаю так:

chmod o+x /home/monkey/site/public
chmod o+x /home/monkey/site
chmod o+x /home/monkey
chmod o+x /home
1
ответ дан 24.11.2019, 14:56

Проверяя относительно твоей ошибки: AH00035 access denied because search permissions пашите missing on в component of the path

Типично разрешения в системе Unix для ресурсов, которые не свойство пользователя или группы, определенной в httpd.conf, его было бы 644 -rw-r - r - для обычных файлов и 755 drwxr-x-r x для каталогов или scripts CGI. Смоги быть необходим, чтобы подтверждать распространенные разрешения (такие как разрешения SELinux) в операционных системах, которые выносят их.

ты нуждаешься кроме того, что применяешь разрешения с

chmod 755

ты должен реализовывать для каталогов:

chmod 644

644 значит, что файлы имеют разрешения чтение и написание владельцем файла и чтения из-за пользователей во владельце группы этого файла и читабельно из-за всех остальных.

1
ответ дан 24.11.2019, 14:56
  • 1
    Я сделал две вещи: 1. То, что ты подробно описываешь ac и # 225; и это каждый sigui и # 243; равный (edit и # 233; вопрос с результатом). 2. Reestablec и # 237; файл httpd.conf и это способствует тому, чтобы index.php внутри /var/www/html/ нагрузил правильно в браузере. Несмотря на то, что я могу тогда работать в этой папке я не хочу счесть эту проблему избежавшей. Следовательно, asign и # 233; директивный орган от DocumentRoot до /home/monkey/site/public/ и проблема разрешений я вернулся и # 243;. – manix 29.01.2016, 20:17

У индейца-апачиа 2.4 есть какие-то изменения в конфигурации разрешений direcorios, проверь https://httpd.apache.org/docs/current/upgrading.html для большего количества деталей

0
ответ дан 24.11.2019, 14:56

Хороший пункт отправления состоит в том, чтобы смотреть LOG ОШИБКИ

для Апачи 2.4 (и для наверху)

AllowOverride All
Require all granted

Мой файл mi-dominio.conf в /etc/apache2/sites-available

<VirtualHost *:80>
    ServerAdmin mi-mail@gmail.com
    ServerName mi-dominio.com
    ServerAlias www.mi-dominio.com
    DocumentRoot /srv/mi-dominio.com/public_html
    ErrorLog /srv/mi-dominio.com/logs/error.log
    CustomLog /srv/mi-dominio.com/logs/access.log combined
    <Directory /srv/mi-dominio.com/public_html/>
        Options Indexes FollowSymLinks MultiViews
        AllowOverride All
        Require all granted
    </Directory>

</VirtualHost>

Есть много путаницы, она mayorГ - в руководителей они продолжают показывать, как конфигурируется для Апачи 2.2

Order allow,deny
Allow from all
0
ответ дан 24.11.2019, 14:56