Проблема, чтобы выполнять мое применение в android studio

оказывается, что я начинаю развивать области применения с android studio, но у меня есть проблема, выполнив мои программы, я использовал участник соревнования android studio, меня загружает все добро, но в момент открытия применения у меня выходит сообщение "применение задержалось", также я попробовал устанавливать архив .apk в мобильном телефоне, Вы основываете правильно но в момент выполнять это выходит та же ошибка. кто-то знает, что Вы можете быть?

спасибо за Ваши ответы.

В logcat у меня выходит следующее исключение:

ФАТАЛЬНЫЙ EXCEPTION: main

java.lang. RuntimeException: Unable to start activity ComponentInfo { com.example.sergio.prueba/com.example.sergio.prueba. MainActivity }: java.lang. IllegalStateException: This app ты существуешь been built with an incorrect configuration. Please образовал your build for VectorDrawableCompat.

Я новый в этом, так что не хорошо, который значит, и как исправление ошибки.

За мной последует то же самое во всех проектах.

import android.support.v7.app.AppCompatActivity;
import android.os.Bundle;

public class ActividadPrincipal extends AppCompatActivity {

    @Override
    protected void onCreate(Bundle savedInstanceState) {
        super.onCreate(savedInstanceState);
        setContentView(R.layout.activity_actividad_principal);
    }
}
1
задан 05.08.2016, 10:33
5 ответов

Возможное решение: Загружать Android studio 2.1.2 и JDK Java 8 "1.8"

Конфигурация Android studio

File->Settings в поле ввода поисков писать gradle

Он должен нам помещать в: Build, Execution, Deployement -> Build Tools-> Gradle

Выбрать Use default gradler wrapper (recomended)

Gradle станет отвечающим совремнным требованиям, смоги опаздывать какие-то минуты

Подтверждать, что используется JDK версия, 8

File->Project Structure секция SDK Location

в JDK Location должен быть чем-то похожим в: C:\Program Files\Java\jdk1.8.0_92

нажимать на секцию app и закладка Propieties в Buil Tools versión, выбирать 24.0.0 и соглашаться.

Также возможно реализовывать изменяя прямо app.gradle

apply plugin: 'com.android.application'

android {
    compileSdkVersion 23
    buildToolsVersion "24.0.0"

    defaultConfig {
        applicationId "com.example.webserveis.myapplication"
        minSdkVersion 19
        targetSdkVersion 23
        versionCode 1
        versionName "1.0"
    }
    buildTypes {
        release {
            minifyEnabled false
            proguardFiles getDefaultProguardFile('proguard-android.txt'), 'proguard-rules.pro'
        }
    }
}

dependencies {
    compile fileTree(dir: 'libs', include: ['*.jar'])
    testCompile 'junit:junit:4.12'
    compile 'com.android.support:appcompat-v7:23.4.0'
    compile 'com.android.support:design:23.4.0'
}
1
ответ дан 24.11.2019, 13:43

Каждый раз, когда он вышел у меня эта ошибка, на которой задерживается приложение, была из-за какой-то ошибки в коде.

Пересмотри код, я рекомендую тебе делать новый проект и это выполнять посмотрим составь все.

Если новый проект выполняет тебя хорошо, ты видишь добавляя части другого приложения пока ты выполняешь проект, до тех пор, пока ты не найдешь код, который производит тебе вышеупомянутую ошибку.

Чтобы мочь давать более специфическое решение нам нужно, чтобы ты присоединил как минимум ошибку консоли, и что-то из кода.

0
ответ дан 24.11.2019, 13:43
  • 1
    Если это только подсказка или сомнения в вопросе, он проистекает " comentar" и не печатать их как ответ. – x4mp73r 04.08.2016, 19:33

У меня была эта же самая проблема и я ссылаюсь на соединение issue, который помог мне решать это! issue, где они говорят тебе, что

С версии 2.0 gradle ресурсы библиотек никогда "rasterizan" следовательно это никогда не произойдет.

buildscript {
...
dependencies {
classpath 'com.android.tools.build:gradle:3.1.0'
 }
}

Пробуй иметь всегда последнюю версию.

0
ответ дан 24.11.2019, 13:43

Soluci¦n для этого - это, чтобы обновлять Ваш Gradle продолжая эту официальную ссылку. Plugin для общеизвестных Андроид Градле versi¦n.

buildscript {

  dependencies {

    classpath 'com.android.tools.build:gradle:2.1.0'
  }

}
0
ответ дан 24.11.2019, 13:43

Возможно была решена с añadir опора imÃ: гены вектора, extra¦-do aquà - .

android {
  defaultConfig {
    vectorDrawables.useSupportLibrary = true
  }
}

dependencies {
  compile 'com.android.support:appcompat-v7:23.3.0'
}
0
ответ дан 24.11.2019, 13:43

Теги

Похожие вопросы