Как исправлять unsupported major.minor версию 52.0 xamarin forms

Я установил JDK и SDK и составив мой проект, у меня вышла следующая ошибка introducir la descripción de la imagen aquí

introducir la descripción de la imagen aquí

1
задан 29.09.2016, 22:08
3 ответа

В Settings для Xamarin. Android обновляет твой JDK в 1.7.0 +, очень вероятно, что имеешь 1.6, и поэтому у тебя вышла ошибка. В твоем SDK Менеджер обеспечь себе иметь обновленного Tools. Если продолжает выходить сообщение, закрой Визуальный Studio, удали bin и obj и вновь откройся: v!

1
ответ дан 24.11.2019, 13:15
  • 1
    пошел человек, в конце концов мы приятно иметь тебя этим очагом, желанный брат: D –  fredyfx 29.09.2016, 21:42
  • 2
    мой JDK - 1.8.0 –  Scott Ariel Perez Quispe 29.09.2016, 21:45
  • 3
    в твоем SDK Менеджер, убедись, что внутри Tools ты считаешь все обновленным –  Moises Alexander Salazar Vila 29.09.2016, 21:47

Уверь, что определенные SDK установлены в действительности, проверь в SDK Manager!

introducir la descripción de la imagen aquí

Помня, у меня была эта проблема в Андроид Студио и разум состоит в том, что он имел определенный, как targetSDK API 24, в конце концов я был должен возвращаться в 23.

0
ответ дан 24.11.2019, 13:15

Эта проблема - по причине разлаживания версии Java. Отнесенный в Wikipedia Java Класс Референсе:

J2SE 8 = 52
J2SE 7 = 51
J2SE 6.0 = 50
J2SE 5.0 = 49
JDK 1.4 = 48
JDK 1.3 = 47
JDK 1.2 = 46
JDK 1.1 = 45

Это ссылка, ошибка, которая у тебя есть,, - потому что, составив, ты используешь один JDK больше и один JDK несовершеннолетний во время выполнения

Чтобы это решать, ты должен иметь JDK и JRE указывая на ту же версию.

0
ответ дан 24.11.2019, 13:15