ОШИБКА ПОСЛЕ ТОГО, КАК СКРОЛЛИРОВАЛИ МОЙ ПРОЕКТ (Ошибка: В JNI ошибка - occurred, please check your installation and try again)

Когда я пробую скроллировать мой проект доказательства (Selenium и testNG) я засолил эту ошибку:

Error: A JNI error has occurred, please check your installation and try again
Exception in thread "main" java.lang.NoClassDefFoundError: com/beust/jcommander/ParameterException
    at java.lang.Class.getDeclaredMethods0(Native Method)
    at java.lang.Class.privateGetDeclaredMethods(Class.java:2701)
    at java.lang.Class.privateGetMethodRecursive(Class.java:3048)
    at java.lang.Class.getMethod0(Class.java:3018)
    at java.lang.Class.getMethod(Class.java:1784)
    at sun.launcher.LauncherHelper.validateMainClass(LauncherHelper.java:544)
    at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:526)
Caused by: java.lang.ClassNotFoundException: com.beust.jcommander.ParameterException
    at java.net.URLClassLoader.findClass(URLClassLoader.java:381)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:424)
    at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:331)
    at java.lang.ClassLoader.loadClass(ClassLoader.java:357)
    ... 7 more

Уже я проверил все книжные магазины и еще я не смог решать это. Я благодарен, в котором они смогли помогать мне.

2
задан 29.09.2016, 19:30
3 ответа

Класс ParameterException не находится:

Caused by: java.lang. ClassNotFoundException: com.beust.jcommander. ParameterException

мне кажется, что остается устанавливать jCommander , если ты используешь gradle, добавляет эту зависимость:

compile "com.beust:jcommander:1.48"

, если ты используешь Maven, добавь:

<dependency>
  <groupId>com.beust</groupId>
  <artifactId>jcommander</artifactId>
  <version>1.48</version>
</dependency>

или используй .jar и добавь это внутри folder /lib, ты это можешь загружать aquГ-!

2
ответ дан 24.11.2019, 13:15

Проверь в jcommander.jar, что этот класс эти ParameterException ahГ-! В этом случае он не из-за нее excepciГіn, который он бросает, ты должен искать одну versiГіn ее librerГ - в более обновленную или более старую, зависит от твоего проекта.

0
ответ дан 24.11.2019, 13:15

introducir la descripción de la imagen aquí

Добавляет другую versiГіn java, потому что ты можешь использовать одну, которая беспокоила бы тебя, потому что в mГ - я беспокоюсь JDK 1.8. Поэтому, я поместил другую и меня compilГі без проблем.

ты даешь Ему второстепенный клик проекту и уходишь в run.

0
ответ дан 24.11.2019, 13:15