Находить первый и последний месяц со стоимостью, отличной от 0

У меня есть следующая таблица в Excel:

| ID | Descripción | Año | Enero | Febrero | Marzo | Abril | Mayo | Junio | Julio | Agosto | Septiembre | Octubre | Noviembre | Diciembre |

За каждый месяц может существовать стоимость между 0 и 10.000. То, что я нуждаюсь в том, чтобы узнать, каков первый и в последнем месяце со стоимостью, отличной от нуля.

А именно, если я имею например: 2015 год, и в месяцы с января в март "0" потом с апреля в октябрь стоимость, отличная от 0 и в конце концов с ноября по декабрь 0 снова, было нужно, чтобы я появился в других 2 колоннах:

Inicio = Abril | Fin = Octubre.

Возможно?

Редактирование: Чтобы находить первого отличного 0 функционирует это:

=COINCIDIR(VERDADERO;D2:02>0;0))

Но для последнего все еще не, как делать.

2
задан 05.04.2017, 01:55
2 ответа

Предполагая, что твоя таблица - asГ-:

ID | Descripción | Año  | Enero | Febrero | Marzo | Abril | Mayo | Junio | Julio | Agosto | Septiembre | Octubre | Noviembre | Diciembre | Inicio       | Fin   
1  | Hola        | 2015 | 0     | 0       | 0     | 1     | 2    | 3     | 4     | 5      | 6          | 7       | 0         | 0         |              |
2  | Ciao        | 2016 | 0     | 0       | 3     | 4     | 5    | 6     | 7     | 8      | 9          | 0       | 0         | 0         |              |

, Чтобы получать первый месяц, podrГ-схвати делать что-то как это для Начала:

=INDEX($D$1:$O$1,MATCH(TRUE,INDEX(D2:O2<>0,),0))

И для Гєltimo месяц немного как это для Конца:

=INDEX($D$1:$O$1,MATCH(TRUE,INDEX(D2:O2<>0,),1))

(сама fГіrmula, sГіlo меняя тип совпадения от 0 до 1). AquГ - я оставляю задержание экрана cГіmo видят в моем Excel:

introducir la descripción de la imagen aquí

Сожалею, использовал Excel в inglГ©s, кажется, что эквивалентов в espaГ±ol serГ-an INDICE для INDEX и COINCIDIR для MATCH, с, то, что quedarГ - в asГ-:

=INDICE($D$1:$O$1,COINCIDIR(TRUE,INDICE(D2:O2<>0,),0))

=INDICE($D$1:$O$1,COINCIDIR(TRUE,INDICE(D2:O2<>0,),1))

Она soluciГіn - вариант ее soluciГіn данная этой ответ в SuperUser .

2
ответ дан 24.11.2019, 12:29
  • 1
    Для ú ltimo оно не функционирует, só это показывает один " 0" – Pepemujica 21.11.2016, 16:03
  • 2
    @Pepemujica ¿ Qué формулируй ты поместил для ú ltimo? ¿ Ты можешь копировать ее aquí? – Alvaro Montoro♦ 21.11.2016, 16:05
  • 3
    =INDICE (D2:O2; СОВПАДАТЬ (ИСТИННЫЙ; ИНДЕКС (D2:O2< > 0;); 1)) – Pepemujica 21.11.2016, 16:08
  • 4
    @Pepemujica fí jate как в fó rmula, который я помещаю, первый ИНДЕКС - на D1:O1 и не на D2:O2, как у тебя есть место. Измени это, попытайся снова и скажи мне có mo пойди – Alvaro Montoro♦ 21.11.2016, 16:09
  • 5
    Я вижу, что оно иногда функционирует и другие не, например, если я помещаю в январе, апреле, июле и октябре стоимость 12500 и в оставшейся части месяцев 0, меня бросает Начало в январе и конец в декабре, когда в действительности deberí чтобы показывать конец ocubre – Pepemujica 21.11.2016, 16:27

Ты можешь использовать ту же функцию ={COINCIDIR(VERDADERO;D2:02>0;0)}, только должен менять Гєltimo ноль на один, для того, чтобы он возвратил тебе Гєltimo, {COINCIDIR(VERDADERO;D2:02>0;1)}

1
ответ дан 24.11.2019, 12:29
  • 1
    Probé но оно не функционирует, просто меня показывает ú ltima ячейка, имейте или нет 0 – Pepemujica 21.11.2016, 16:02